HomeKit Beta

Hello tedee users,

We've been working hard on HomeKit integration. In the upcoming weeks we will release few beta versions for mobile and devices and we'll ask you for help. Please note that the "beta" versions may be unstable. By joining the testing program, you acknowledge that application may not match quality standards as a regular version does.

How to join for Android Beta

If you want to join the beta program please sign up for using this link or directly from Google Play app link.

You can leave the testing program any time using the same link and install the public version from store.

How to join for iOS Beta

You can join iOS beta using this public link.

In order to install the app, you will need to download and open TestFlight. Please follow the steps from the manual: https://testflight.apple.com/.

To leave testing program, you can delete yourself as a tester in the app’s Information page in TestFlight by tapping Stop Testing and install the public version from store.

Version 1.115.01 beta (iOS), beta (Android)

This version introduce new way of discovering and connecting to tedee devices via Bluetooth that will be released later with a HomeKit firmware update. During this test we want to make sure that backward combability is working and users doesn't have issues with connecting to exiting devices via Bluetooth.

What to test:

  • Check if adding device process is working
  • Check if you can update device firmware from mobile
  • Check if you can unlock/lock the lock from phone/widget via Bluetooth
  • Check if Apple Watch is working

We already have tested this and everything worked fine. Please share your feedback under this post.

5 people like this

Lars I moved the conversation to separate thread: HomeKit comunication issue (Lars) : Tedee (freshdesk.com)

Lars N.

okay !

what IOS do you use? 15.0? 15.01? I use such a system Iphone X and Ipad 8th generation

If it is not the fault of the software, it remains to replace the Tedee lock

You have already checked everything that could have caused the lock to malfunction.

new homepod + lock tedee showed a bug

This is what it looks like :)

I have checked with a HomePod mini that I borrowed. Same results

1 person likes this

Lars N.

proposes to do experience….  buy or borrow HomePod mini with the option to return and pair the tedee with HomePod again and check ... then you will eliminate everything possible for 100%

The lock is working properly in the Tedee App. From Auto Unlock, Calibration, Pull Spring to the button (Delayed locking, opening) everything is as it should.

It's just that it seems to lose connection in native homekit, while it keeps being connected over homebridge-plugin, which you correctly pointed out, works over the bridge connection. 

I don't think the lock is broken, but it seems that it doenst work properly in some homekit configurations or under certain circumstances. Can't figure out what the problem is from my end.

Lars N. 

with Tede's in-house app working fine?

I think if Tedee is serious about their products and quality they would offer some help instead of letting the customer search for bugs.

In the meantime I have resettet the Homekit network, builded it up new much to my wife's suspicion.

Haven't got the time to add the roller blinds again, but the lock was reacting at first and stopped shortly afterwards. Every request is leading to a timeout. I have added the other devices which are acting quick and as they should. 

And as for my HomeKit configuration. As you know there is none. You add devices and they work ( or don’t). Nothing I really can’t check or modify without external help from someone who knows the standard.
Dear David, well I removed the homebridge lock in HomeKit, deinstalled the plugin a couple of days before release. The lock was working in HomeKit but now I can’t reach it. I think it’s working after I add it but getting unresponsive after a while. The suggestion to remove everything is something I wouldn’t start with. That is something last resort if the supplier (Tedee) has no idea and cannot provide any help. So far no one has looked into anything.

Hello Lars,

Are you still using Homebridge for any other non Homekit devices ? 

Would it be possible that your previous Tedee lock Homebridge implementation is somehow interfering with the new Native HomeKit version ?

I am not a homebridge expert, but since other users have no issue with HomeKit native Tedee lock, it is probable there is something in your "home" config that is causing the problem.

I know this is a nightmare to do, but have tried re-installing every device from scratch ?

If I were you and serious about finding the culprit, I would erase my HomeKit and Homebridge configs and start by installing the Tedee Lock in HomeKit. Then I would try to add the other devices one by one (testing the lock every time until I would find the source of the problem.

I sincerely hope you find a solution and perhaps Tedee will be able to help you with troubleshooting (after all, it is in their interest to squash any bugs you find).

Good luck Lars,


Well in the current state I cannot use native HomeKit because the lock not reacting to anything. Any other HomeKit (native or not) device is working. I don’t see myself coming to a solution. Are you interested in solving this or do you keep blaming me without further investigation?

It works for me here without a hitch. There is a slight delay when using the home app, but it is barely noticeable.

Because then it really works over our bridge and not over a HomeKit hub.

Maybe it’s because my Home has two hubs, several devices (65) and four bridges. Why is the Tedee lock working great on the same hubs with a simulated HomeKit over Homebridge?
It works for me and there are no problems. Tedee opens with AppleWatch, iPhone, Homepod, Siri, no lag is ok