HomeKit Beta

Hello tedee users,

We've been working hard on HomeKit integration. In the upcoming weeks we will release few beta versions for mobile and devices and we'll ask you for help. Please note that the "beta" versions may be unstable. By joining the testing program, you acknowledge that application may not match quality standards as a regular version does.

How to join for Android Beta

If you want to join the beta program please sign up for using this link or directly from Google Play app link.

You can leave the testing program any time using the same link and install the public version from store.

How to join for iOS Beta

You can join iOS beta using this public link.

In order to install the app, you will need to download and open TestFlight. Please follow the steps from the manual: https://testflight.apple.com/.

To leave testing program, you can delete yourself as a tester in the app’s Information page in TestFlight by tapping Stop Testing and install the public version from store.

Version 1.115.01 beta (iOS), beta (Android)

This version introduce new way of discovering and connecting to tedee devices via Bluetooth that will be released later with a HomeKit firmware update. During this test we want to make sure that backward combability is working and users doesn't have issues with connecting to exiting devices via Bluetooth.

What to test:

  • Check if adding device process is working
  • Check if you can update device firmware from mobile
  • Check if you can unlock/lock the lock from phone/widget via Bluetooth
  • Check if Apple Watch is working

We already have tested this and everything worked fine. Please share your feedback under this post.

5 people like this

Hey Lars, there is no such thing as "implementation" for it suggests there is more than one way to "implement" how HomeKit works. It's Boolean: true or false. You pass the certification or you fail. BTW, do you have any other battery-operated locks in your network to compare? Homebridge is almost as fast as the bridge and it's not any surprise. It's just something completely different.  Whatever is left to be fixed, it's not our "implementation". Have a good one!

No I don’t have another lock. There’s no reaction from my lock over HomeKit. It doesn’t update and any action lead to timeout. Lock is working over tedee App and homebridge plugin over HomeKit, but shows strange behaviour over native HomeKit. If you think that is normal you are trying to downplay the issue. That’s fine for me as I have found a working solution. It seems like the lock is going to sleep after a while because right after I add it to native HomeKit it’s working normal.
You may want to look into this so I can provide logs, but as far as I have followed the discussion you didn’t seem interested.
I cannot get the lock to answer. Sometimes it’s working but most time it doesn’t
It works for me and there are no problems. Tedee opens with AppleWatch, iPhone, Homepod, Siri, no lag is ok
Maybe it’s because my Home has two hubs, several devices (65) and four bridges. Why is the Tedee lock working great on the same hubs with a simulated HomeKit over Homebridge?

Because then it really works over our bridge and not over a HomeKit hub.

It works for me here without a hitch. There is a slight delay when using the home app, but it is barely noticeable.

Well in the current state I cannot use native HomeKit because the lock not reacting to anything. Any other HomeKit (native or not) device is working. I don’t see myself coming to a solution. Are you interested in solving this or do you keep blaming me without further investigation?

Hello Lars,

Are you still using Homebridge for any other non Homekit devices ? 

Would it be possible that your previous Tedee lock Homebridge implementation is somehow interfering with the new Native HomeKit version ?

I am not a homebridge expert, but since other users have no issue with HomeKit native Tedee lock, it is probable there is something in your "home" config that is causing the problem.

I know this is a nightmare to do, but have tried re-installing every device from scratch ?

If I were you and serious about finding the culprit, I would erase my HomeKit and Homebridge configs and start by installing the Tedee Lock in HomeKit. Then I would try to add the other devices one by one (testing the lock every time until I would find the source of the problem.

I sincerely hope you find a solution and perhaps Tedee will be able to help you with troubleshooting (after all, it is in their interest to squash any bugs you find).

Good luck Lars,


Dear David, well I removed the homebridge lock in HomeKit, deinstalled the plugin a couple of days before release. The lock was working in HomeKit but now I can’t reach it. I think it’s working after I add it but getting unresponsive after a while. The suggestion to remove everything is something I wouldn’t start with. That is something last resort if the supplier (Tedee) has no idea and cannot provide any help. So far no one has looked into anything.
And as for my HomeKit configuration. As you know there is none. You add devices and they work ( or don’t). Nothing I really can’t check or modify without external help from someone who knows the standard.
Firmware update is here

Nothing for me yet !!!!

How did you get it ? Did it just appear in the app ?