Start a new topic

Slow API and Portal

For some time (weeks/months) I have noticed that the API (and apparently at the same time the portal) is very slow for a long time.

I query the lock status every minute. The query freezes for several seconds and blocks further processing. I am currently using API v1.22. I have been using the API for a long time and it was always sufficiently fast initially. I specially changed from "username/password" to "personal token" without improvement.

It is quite annoying. Is there a change to improve the server performance?


Thank you for submitting that. We have already improved it and now it should work a lot better. We are sorry for the inconvenience. 

Yes, thank you. I have also noticed that it currently works much better again. I continue to observe it.

small observation:

I have noticed that almost every day between 17:00 and 19:00 the portal and API becomes very very slow. First I thought always around 18:00 clock, but today, for example, much earlier. This has been the case for weeks. Sometime after a long time it works again normal fast.


1 person likes this

Thank you for reporting that. We will check it and get back to you with an answer. 

I support this thread. Like I mentioned in the local REST API thread some minutes ago, it's really annoying.


2 days ago there was over a minute of a delay. In a bad luck moment, it could be, that I try to unlock, the lock doesnt response, I take the key, catch something up and go out again. 30 seconds later the door opens then...


it almost happened two times in the last 2 months.

I didn't like being annoyed anymore and changed my query to "threaded". Since I only query it is ok for me, but if you want to use automations over the at times slow API it is scary.

By my change I don't see anymore if the problem of the slow API has improved. Sometimes I still go to the portal, here you would also recognize the slow API when it occurs.

Login to post a comment